New RCE Flaw in Apache Struts - Apache Commons FileUpload Library

The Apache Software Foundation has released an advisory to address a vulnerable commons-fileupload library used in Apache Struts versions 2.3.36 and prior. A remote attacker could exploit this vulnerability to take control of an affected system. Struts versions from 2.5.12 are not affected.

By exploiting this vulnerability, it is possible to perform a Remote Code Execution (RCE) attack.

Affected Versions

  • Struts 2.3.36 and prior

Recommended Course of Action

Upgrade to the latest released version of Commons FileUpload library, which is currently 1.3.3. Deployed applications can be hardened by replacing the commons-fileupload jar file in WEB-INF/lib with the fixed jar. For Maven based Struts 2 projects, the following dependency needs to be added:

<dependency>
  <groupId>commons-fileupload</groupId>
  <artifactId>commons-fileupload</artifactId>
  <version>1.3.3</version>
</dependency>

More Information

footerimage

Member of

logo apcertfirst logo-2

Collaborated with

apwg2ICTA logo2ack cymru

Our Partners
lanka-certify-logoDark-Lab-Logo2contact